Michael Allan's files

Icon  Name                    Last modified      Size  
[PAR] Parent Directory - [DIR] builds/ 2011-04-05 19:01 - [   ] votorola-0.2.0.tar.gz 2009-05-10 04:50 18M [   ] votorola-0.2.1.tar.gz 2009-07-03 21:44 18M [   ] votorola-0.2.2.tar.gz 2009-10-20 00:48 18M [   ] votorola-0.2.3.tar.gz 2011-06-08 03:11 23M

These are the most "recent" releases of Votorola in GZIP format. See also the interim builds and the full archive of older releases and ZIP format packages. Two important things to understand: (1) You probably want to be a developer before attempting to install Votorola. It is still a prototype and the installation is hairy. See the developers section below. (2) No the project is not dead. New releases are only made on request, typically when a new developer joins. The latest code is always available in the repository, including the latest manual; but the installation instructions in the manual are only tested at release time.

Versions 0.2.2 or older

If you are installing a build newer than 0.2.2, then you needn't read this section. The information is already in your installed docs.

PostgreSQL 8.3+ is recommended. Subsequent upgrading to PostgreSQL 8.3+ is difficult for any application that uses the tsearch2 module, such as MediaWiki. So if you start with an older version of PostgreSQL then you might have to reinstall MediaWiki from scratch at a later date.

It is also recommended that you install Semantic MediaWiki before creating any pages. See the instructions for setting up the pollwiki.

Developers

It helps to know what part you are interested in first. You probably want some experience as a user. Learn as much as possible before proceeding. Again, the installation is hairy. Install the bare minimum for the part you need and leave the rest for later. If you need help at some point (very likely), please post to the mailing list or ping us on freenode #votorola.

Developers should install the most recent package from either the releases (above) or the interim builds, whichever has the latest package. If both look out of date (very likely), then ask in the list and we'll cut you a new build. This will save you time and effort.

After installing and testing the package above, refer to the build instructions.